MakerSketch Docs
Colour scheme
Light or dark

Appendix

Sketch commands

The commands you can run in a sketch or a drawing. Type a command's name or one of its short forms, or pick it from its menu. First prompt is what the command asks for first.

Edit

Command Type Menu Shortcut First prompt
Paste pasteclip Edit › Paste Cmd+V
Select All selectall, ai_selall Edit › Select All Cmd+A

Draw

Command Type Menu Shortcut First prompt
Line line, l Draw › Line Specify first point:
Polyline pline, pl Draw › Polyline Specify start point:
Circle circle, c Draw › Circle › Center, Radius Specify center point for circle or [3P/2P/Ttr (tan tan radius)]:
Arc arc, a Draw › Arc › 3 Points Specify start point of arc or [Center]:
Rectangle rectang, rec, rectangle Draw › Rectangle Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]:
Polygon polygon, pol Draw › Polygon Enter number of sides <4>:
Ellipse ellipse, el Draw › Ellipse › Center Specify axis endpoint of ellipse or [Arc/Center]:
Spline spline, spl Draw › Spline › Fit Points Specify first point or [Method/Knots/Object]:
Single Line Text text, dt, dtext Draw › Text › Single Line Text Specify start point of text or [Justify/Style]:
Multiline Text mtext, t, mt Draw › Text › Multiline Text... Specify first corner:

Without a menu

Command Type Menu Shortcut First prompt
Control Vertices spline.cv Specify first point or [Method/Degree/Object]:
Set Size size
Grip Stretch grip.move
Grip Stretch grip.stretch
Grip Rotate grip.rotate
Grip Scale grip.scale
Grip Mirror grip.mirror
Grip Option grip.option
Grip Edit grip Select grip:
New Layer layer.new
Set Layer Properties layer.set
Set Properties properties.set

Modify

Command Type Menu Shortcut First prompt
Erase erase, e, delete Modify › Erase Select objects:
Move move, m Modify › Move Select objects:
Copy copy, co, cp Modify › Copy Select objects:
Rotate rotate, ro Modify › Rotate Select objects:
Scale scale, sc Modify › Scale Select objects:
Mirror mirror, mi Modify › Mirror Select objects:
Stretch stretch, s Modify › Stretch Select objects:
Offset offset, o Modify › Offset Specify offset distance or [Through/Erase/Layer] <Through>:
Trim trim, tr Modify › Trim Select object to trim or shift-select to extend or [cuTting edges/Fence/Crossing/mOde/Project/eRase/Undo]:
Extend extend, ex Modify › Extend Select object to extend or shift-select to trim or [Boundary edges/Fence/Crossing/mOde/Project/Undo]:
Fillet fillet, f Modify › Fillet Select first object or [Undo/Polyline/Radius/Trim/Multiple]:
Chamfer chamfer, cha Modify › Chamfer Select first line or [Undo/Polyline/Distance/Angle/Trim/mEthod/Multiple]:
Explode explode, x Modify › Explode Select objects:
Break break, br Modify › Break Select object:
Join join, j Modify › Join Select objects:
Gap Between Lines gap, linegap Modify › Gap Between Lines Select the line that stays:
Rectangular Array arrayrect Modify › Array › Rectangular Array Select objects:
Polar Array arraypolar Modify › Array › Polar Array Select objects:
Lengthen lengthen, len Modify › Lengthen Select an object to measure or or [DElta/Percent/Total/DYnamic] <DYnamic>:
Edit Text... textedit, ed, ddedit Modify › Object › Edit Text... Select an annotation object or [Undo/Mode]:
Properties properties, pr, props, ch Modify › Properties

Format

Command Type Menu Shortcut First prompt
Layers layer, la, layers Format › Layers
Make Current layer.current, clayer Format › Layer Tools › Make Current
Units... units, un Format › Units...

Tools

Command Type Menu Shortcut First prompt
Distance dist, di Tools › Inquiry › Distance Specify first point:
ID Point id Tools › Inquiry › ID Point Specify point:
Area area, aa Tools › Inquiry › Area Specify first corner point or [Object/Add area/Subtract area] <Object>:

Keyboard shortcuts

With a hardware keyboard; hold ⌘ to see them in the app.

Action Keys
Undo ⌘Z
Redo ⇧⌘Z
Move Part ⇧⌘M
Cut ⌘X
Copy ⌘C
Paste ⌘V
Duplicate ⌘D
Delete Delete
Select All ⌘A
Search Tools ⌘K
Cancel Esc
Set Value Return
Bigger ↑
Smaller ↓
Fit View ⌘0
Outline from Face ⇧⌘O
Export… ⇧⌘E
Show Assembly ⌥⌘A
Show Make ⌥⌘P
Show Make ⌥⌘B
Next Panel ⌃Tab
Previous Panel ⌃⇧Tab